2018 Spring Release

Working with ListsPermanent link for this heading

Teamrooms and folders show the contained objects in the content area as a list. Three different list views are provided.

Content View

The content view is displayed per default. In this list, the most important information for the objects is shown.

Detail View

In the detail view, you can modify the column settings to get more information about the listed objects.

Preview

In the preview, you can find the most important meta data and the preview of the object. For documents, the first pages are displayed.

Selecting EntriesPermanent link for this heading

Several objects in a list can be selected to edit them concurrently.

Select several objects

To select several objects in a list, click the objects while keeping the Ctrl key pressed or mark them via the “Selection” box.

  • In the content view, the “Selection” box is displayed when you hover with the mouse over the right side of the line. In the preview you have to hover over with the mouse over the left side of the line.
  • In the detail view, the “Selection” box is displayed left to the first column.
  • In the card view, the “Selection” box is shown below the cards.

Select an area

To select an area of an object list, select the first entry and press the Shift key. Keep the Shift key pressed and select the last entry of the area you want to select. Doing so, all objects between the two entries are selected.

Select all entries

Select the box in the column header to select all entries (only detail view).

Change the ViewPermanent link for this heading

To switch between the views, open the context menu of the content area.

  1. Open the context menu of an empty part of the content area and click “Change View”.
  2. Select the desired view.

Sorting Objects Within a ListPermanent link for this heading

The sorting of objects in a list can be easily adapted. You can sort objects depending on various criteria in an ascending or descending order. It is also possible to sort objects depending on several criteria at the same time.

You can define the sorting by clicking the number of entries in the upper right corner. Alternatively, you can use the context menu of the content area.

In the detail view, you can also sort the entries via the column header. The detail view provides additionally the possibility to group a column, to fix a column or to filter the entries depending on a search criterion.  

Modify Column SettingsPermanent link for this heading

The columns of the detail view can be adjusted depending on your needs.

  1. To add a column, perform the following steps:
  2. Select the object in the list that provides the property you want to add.
  3. Open the context menu of a column in the column header.
  4. Click „Add Column“.
  5. Select the desired property.

Note:

  • Which properties are available as columns depends on the type of the object that is selected in the list.
  • For columns that contain objects, properties of these objects can be displayed via the “Next Level” context menu command.
  • For compound properties, the properties of the compound property can be displayed via the “Details” context menu command.
  • To move a column to the right or left, use the “Move to” context menu command. You can also move columns with drag and drop.
  • To optimize the width of the column according to the length of the content, double-click in the column header between two columns.
  • To remove a column, use the “Remove” context menu command.

Column Editing in the Details ViewPermanent link for this heading

If you mark a cell and press the F2 key, you can directly edit the content of the cell.

For efficient editing of several objects at the same time possibilities similar to a spreadsheet program are provided in the detail view.

Editing possibilities:

  • copy (Ctrl + C)
  • cut (Ctrl + X)
  • paste (Ctrl + V)
  • delete (Del key)

Several even not adjacent cells within a column can be copied and pasted at the same time. If the number of selected cells when pasting is greater than the number of selected cells when copying, then it is started over with the first value. If fewer cells are selected when pasting, only values in the selected cells are changed.

Note: Under Linux, no empty object pointers are copied.

The values can also be copied from the Fabasoft Private Cloud and pasted e.g. in Microsoft Excel. Pasting values from third-party products in the Fabasoft Private Cloud is only conditionally possible (depending on the clipboard format of the third-party product).

Copy Data TablePermanent link for this heading

If you enable the menu bar, you can use the “Clipboard” > “Data Table” > “Copy” menu command to copy the list in the clipboard and paste it for example in Microsoft Excel. If some lines are selected, only those lines will be copied to the clipboard. The order in which the lines were selected is taken into account.

Note: If you choose "Copy Extended", additionally to the visible columns also entries of shown object lists and all values of aggregates and aggregate lists are copied as nested table.

InfoboxPermanent link for this heading

The infobox is displayed after about one second, if your mouse is placed over the check box or symbol of a selected object and not moved. This way you get the most important information without the need to open the object.

Note: You can disable the infobox in the “Base Settings” with the Show Hints option.